Debian

Debian Jessie から Stretch へのアップグレード

6月17日、Debianの2年振りのメジャーアップデートが行われ、stretch(v9)がstableに昇格した。wheezy(v7)からjessie(v8)へのアップデートの場合は、initからsystemdへの変更という大きな問題があったためクリーンインストールを行った。だが今回は、ク…

[Debian] Jessieはクリーンインストールしよう

以前書いたように、普段使っているPCをJessieにアップグレードしたのだが、うまく行かなかった。記事に書いたfglrx-driverの件は乗り越えたが、grubで躓いた。update-grubが落ちる。その原因は、/usr/sbin/grub-probe。「`.'」というデバイスがどうのと、訳…

[Debian] fglrx-driver on jessie

このブログは最近まで開店休業で、AMDのRADEON用ドライバについて書くぐらいだったのだが、今日はその話。Debianのjessieがフリーズされてからだいぶ立つが(2014-11-05)、リリースクリティカルバグの減り方を見ると、3月中にリリースされる可能性がある。そ…

[Debian] fglrx-driver-13.12

fglrx-driverのまともな奴がやってリリースされた。Debianでもunstable(sid)で公開されている。以前の記事で述べたように、fglrx-driverの開発遅れ(?)の影響で、Radeonユーザは迷惑している。新しいドライバ類は、次のようにインストールできる。 $ sud…

[Debian] fglrx-driver その後

fglrx-driverがjessie(=testing)から消えたのは、ATIのfglrx-driver-13.4がxserver-1.14に対応していないからのようだ。ATIの新版はまだbeta版なので、testingとしては導入しようがない。新版はexperimentalにのみ存在する。結局、悪いのはATIだったというこ…

[Debian] fglrx-driver パッケージが weezy-backports,jessie から消えた

理由が不明なのだが、fglrx-driverをソースとするパッケージ群が wheezy-backports から消えた。1ヶ月以上前のことだ。ちょうど、linux-image-3.10-0.bpo.2-amd64 が導入された時だ。ところが、linux-image-3.10-0.bpo.2-amd64 は、ATI/AMD RadeonHD display…

[Debian] GNOME3のメニューが消えた

以前にも起こったのだが、今朝Wheezyを起動すると、GNOME3のメニューが消えた。 アクティビティが空になった Dockステーションが空になった この際の処置は、Ctrl+Alt+F1(or F2-F6)でターミナルを切り替えてログインし、 $ rm -r ~/.config/menusもちろん、…

[Debian] GNOME3が使える

今まで、GNOME-ShellとかUnityと言った新しいUIを毛嫌いした。今度DebianがWheezyになって、勝手にGNOME3(GNOME-Shell)になった。ところが使ってみると結構使える。リーナス・トーバルスもGNOME3に戻ったようだ。それは、gnome-tweak-toolとDock拡張のためだ…

[Debian] Wheezy Released

遅ればせながら、Wheezyがリリースされた。 ------------------------------------------------------------------------ The Debian Project http://www.debian.org/ Debian 7.0 "Wheezy" リリース press@debian.org 2013年 5 月 4 日 http://www.debian.or…

[Debian] Hieroglyph

Squeeze で Hieroglyph を使うには ttf-ancient-font パッケージをインストールする

[Debian] Redmine

まだこのブログでは扱っていないが、Redmine を仕事で多用している。現在、Squeeze では、redmine-1.0.5 になっている。Redmine はできるだけ新しい方が良い。ところが、lenny-backports では現在、1.0.5 のため、unstable からインストールすることにした。…

[Debian] gdm3

Squeezeをスクラッチでインストールすると gdm3 になるが、アップグレードすると gdm のままのようだ。改めて gdm3 をインストールしなければならない。なお、gdm3 のメリットはまだ私にはわからない。まもなく gdm-3.0 が出るようで、gdm-2.3(gdm3のこと)…

[Debian] Firefox4 for Linux_x86_64

Firefox4が出ている。かなり使いよくなっているが、Debianのiceweaselはまだ、3.5.Xのまま。是非とも使いたい各位は、直接にダウンロードされたい。このリンクは4.0.1なので適宜、変更されるように。なお現在、http://www.mozilla.org/からたどると、32bit用…

[Debian] Debian Squeeze その3

サーバマシンをSqueezeにアップグレードする際、問題が生じた。 emacsen-common latex-cjk-common latex-cjk-thai この2つのパッケージが、prerm で異常終了する。そのため、全てのアップグレードが止まる。 その原因はスクリプト /usr/lib/emacsen-common/…

[Debian] Debian Squeeze その2

昨日に引き続いて、squeeze。 grub2 squeezeからgrub2を使うことにする。今ひとつ設定が分からないので放っておいたが、時代の流れなので仕方がない。起動時のコンソールが640x480なのでたいへん不細工で読みにくい。grubではカーネルオプションに vga=791 …

[Debian] Debian Squeeze

Debian Squeeze (6.0) がリリースされた。うかつなことに2週間近く気がつかなかった。最近はDebianのMLをサブフォルダに入れてしまうので、見ないことが多い。squeezeのフリーズさえ知らなかった。MLのメールが多いので仕方ないが。 upgrade の手順 当然の…

abinit on lenny

abinit を lenny でコンパイルする手順。 # sudo apt-get build-dep abinit # sudo apt-get install gfortran openmpi-bin libopenmpi-dev patch # tar -xzf abinit-XXX.tar.gz # cd abinit-XXX # ./configure --with-linalg-libs="-llapack-3 -lblas-3" --e…

Tomcat5.5 のインストール

# aptitude install sun-java6-bin # aptitude install tomcat5.5 # aptitude install libtcnative-1 # (aptitude install tomcat5.5-admin tomcat5.5-webapps)後は連鎖的にインストールされる。なお最後のカッコ内は必須ではない。libtcnative-1 については…

しゃべる on lenny

Twitterクローンのしゃべるを使う必要ができたので、インストールを試みた。全自動でインストールできるのはよいのだが、mysql、tomcat、jre などを別バイナリでインストールしてしまうこと、debian の習慣と違うディレクトリを使用するなどの問題があるので…

[Debian] gedit の印刷設定(マージンを変える)

メニューから、ファイル -> ページ設定 -> 用紙のサイズ -> その他のサイズ を選択し、マージンを設定する。設定の名前が、最初は「その他のサイズ1」などとなっているから、これを適宜変更して Enter する(Enter しないと名前が変更されない)。最後に設…

[Debian] 「この APT が対応している以上の数の説明が要求されました。」

sid を aptline に加えると、aptitude update で次のようなエラーがでる。 E: この APT が対応している以上の数の説明が要求されました。 E: Problem with MergeList /var/lib/apt/lists/cdn.debian.or.jp_debian_dists_sid_main_i18n_Translation-ja E: パ…

ATI 純正ドライバ

グラフィックドライバの不具合 突然グラフィックドライバが機能しなくなった。起動時にXがエラーを起こす。/etc/X11/xorg.conf を編集して、ATI純正のfglrxからvesaに変えて立ち上げることはできた。何が原因か分からない。直前にカーネルパッケージのアップ…

debian lenny その後

2010年9月27日現在、flashplugin-nonfree パッケージが更新されたようだ。ただし、まだ unstable にしかなく lenny-backports はまだ対応していないが、lenny でも直接にダウンロードしてインストールすることが可能である。これに伴い、上記 Wiki から対応…

debian lenny の対応

debian でも、まだ、flashplugin-nonfree パッケージでの対応は出ていないようだが、Wiki にSquare への対応方法を掲載している。早速、インストールしてみた(公開されたプラグインライブラリを1個入れるだけ)のだが、動作がおかしかった radio.jp が聞け…

KVM-VNC 付加情報

KVM.

[Debian][KVM] 仮想マシンはVNC接続で

その後 kvm を使っていろいろ不便なこともあり、当初の使用手順を変更することにした。 仮想マシンマネージャ(virt-manager)を止めた virt-manager は、まだ使い勝手が悪いように思う。前にも書いたように usb を使用するのに面倒な手順が要る。またゲスト…

[Debian][KVM] 仮想マシンでシリアルUSBケーブルを使う

仮想マシン上の Windows 2000 でモバイル用アプリケーションを開発するためには、転送用のUSBケーブルを使用する必要がある。USB デバイスを仮想マシンで使用するための例として、Windows 2000 にこのUSBケーブルを登録する手順を示す。Windows XPでも基本手…

[Debian] thunderbird on lenny

iceweasel と icedove debian では firefox と thunderbird が無い。debian と mozilla の意地の張り合いで其々、iceweasel と icedove に名前が変えられている。お互いの主張はよくわかるので、それはそれでいいのだが、iceXXX のバージョンが古いのは困る…

[Debian][KVM] kvm を使う

Windows 2000のサポート切れを控えて、lennyをホストOSにする仮想マシンに載せかえることにした。仮想マシンとしてはXenも試してみたが、RedHatが力を入れているkvmを採用することにした。現状では、開発段階はXenの方が上のようだが、これからに期待しよう…

kernel 2.6.32-bpo.5-amd64 の起動中に60秒停止する

次のメッセージを出力して、次に進むので、致命的ではないが。 eth0: unable to apply firmware patchBug#561309 に関連すると思う。firmware-linux-nonfree パッケージと firmware-linux-free パッケージをインストールしたら、解消したようだ。理由はわか…