読者です 読者をやめる 読者になる 読者になる

[Debian] 「この APT が対応している以上の数の説明が要求されました。」

sid を aptline に加えると、aptitude update で次のようなエラーがでる。

E: この APT が対応している以上の数の説明が要求されました。
E: Problem with MergeList /var/lib/apt/lists/cdn.debian.or.jp_debian_dists_sid_main_i18n_Translation-ja
E: パッケージ一覧または状態ファイルをパースできませんでした、または開けませんでした。

おそらく、日本語の説明文を解析できないため。この解決法は、/etc/apt/apt.conf.d/99XXXX (XXXX=適当な名前)に

APT::Acquire::Translation "none";

を加える。